Detect and document dependency on -ldl on Linux, -lc on BSD for dlopen
[lttng-ust.git] / tests / hello-static-lib / Makefile.am
index 0eff080cdd2bb4746299b9fd90a1d9a6bf203ce0..6633489424a388db1f375e5aefa3e14f8746f66e 100644 (file)
@@ -8,7 +8,14 @@ liblttng_ust_provider_ust_test_hello_la_LIBADD = \
 
 noinst_PROGRAMS = hello
 hello_SOURCES = hello.c
-hello_LDADD = -ldl liblttng-ust-provider-ust-test-hello.la
+hello_LDADD = liblttng-ust-provider-ust-test-hello.la
+
+if LTTNG_UST_BUILD_WITH_LIBDL
+hello_LDADD += -ldl
+endif
+if LTTNG_UST_BUILD_WITH_LIBC_DL
+hello_LDADD += -lc
+endif
 
 noinst_SCRIPTS = run
 EXTRA_DIST = run
This page took 0.023009 seconds and 4 git commands to generate.