Fix: Conditionally disable tests requiring shared libs support
[lttng-ust.git] / tests / demo / Makefile.am
index e4570ff0a694d9fea50f14f5ed8e89696832e7a1..5adafdc5ff31e892e768a030633ce5cff0e3367c 100644 (file)
@@ -1,11 +1,15 @@
 # -Wsystem-headers is needed to print warnings in the tracepoint
 # description file.
-AM_CPPFLAGS = -I$(top_srcdir)/include -Wsystem-headers
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
 # Set LIBS to nothing so the application does not link on useless
 # libraries.
 LIBS =
 
+if NO_SHARED
+# Do not build this test if shared libraries support was
+# explicitly disabled.
+else
 # Force the shared flag on the noinst libraries since they are
 # only built static by default
 FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
@@ -33,11 +37,6 @@ liblttng_ust_provider_ust_tests_demo3_la_LDFLAGS = \
 
 noinst_PROGRAMS = demo
 demo_SOURCES = demo.c ust_tests_demo.h
-# The demo program only depends on libdl/libc for dlopen().
-if LTTNG_UST_BUILD_WITH_LIBDL
-demo_LDADD = -ldl
+# The demo program only depends on libdl.
+demo_LDFLAGS = -ldl
 endif
-if LTTNG_UST_BUILD_WITH_LIBC_DL
-demo_LDADD = -lc
-endif
-
This page took 0.023652 seconds and 4 git commands to generate.