Fix: Conditionally disable tests requiring shared libs support
[lttng-ust.git] / tests / demo / Makefile.am
index 4e113edc87705e0c9654d68b5b589df5e493533e..5adafdc5ff31e892e768a030633ce5cff0e3367c 100644 (file)
@@ -1,18 +1,20 @@
 # -Wsystem-headers is needed to print warnings in the tracepoint
 # description file.
-AM_CPPFLAGS = -I$(top_srcdir)/include -Wsystem-headers
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
 # Set LIBS to nothing so the application does not link on useless
 # libraries.
 LIBS =
 
+if NO_SHARED
+# Do not build this test if shared libraries support was
+# explicitly disabled.
+else
 # Force the shared flag on the noinst libraries since they are
-# only build static by default
+# only built static by default
 FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
                           -rpath $(abs_builddir)
 
-PROBE_LIBS = -lurcu-bp -lurcu-bp -luuid -lpthread -ldl
-
 noinst_LTLIBRARIES = liblttng-ust-provider-ust-tests-demo.la \
        liblttng-ust-provider-ust-tests-demo3.la
 
@@ -23,8 +25,7 @@ liblttng_ust_provider_ust_tests_demo_la_SOURCES = \
 liblttng_ust_provider_ust_tests_demo_la_LIBADD = \
        $(top_builddir)/liblttng-ust/liblttng-ust.la
 liblttng_ust_provider_ust_tests_demo_la_LDFLAGS = \
-       $(FORCE_SHARED_LIB_OPTIONS) \
-       $(PROBE_LIBS)
+       $(FORCE_SHARED_LIB_OPTIONS)
 
 #contains ust_tests_demo3.h provider probes
 liblttng_ust_provider_ust_tests_demo3_la_SOURCES = \
@@ -32,16 +33,10 @@ liblttng_ust_provider_ust_tests_demo3_la_SOURCES = \
 liblttng_ust_provider_ust_tests_demo3_la_LIBADD = \
        $(top_builddir)/liblttng-ust/liblttng-ust.la
 liblttng_ust_provider_ust_tests_demo3_la_LDFLAGS = \
-       $(FORCE_SHARED_LIB_OPTIONS) \
-       $(PROBE_LIBS)
+       $(FORCE_SHARED_LIB_OPTIONS)
 
 noinst_PROGRAMS = demo
 demo_SOURCES = demo.c ust_tests_demo.h
-# The demo program only depends on libdl/libc for dlopen().
-if LTTNG_UST_BUILD_WITH_LIBDL
-demo_LDADD = -ldl
-endif
-if LTTNG_UST_BUILD_WITH_LIBC_DL
-demo_LDADD = -lc
+# The demo program only depends on libdl.
+demo_LDFLAGS = -ldl
 endif
-
This page took 0.024761 seconds and 4 git commands to generate.