Fix: Conditionally disable tests requiring shared libs support
[lttng-ust.git] / tests / demo / Makefile.am
index 40e43690e11c28a2a41faa4646206a92990f9378..5adafdc5ff31e892e768a030633ce5cff0e3367c 100644 (file)
@@ -1,12 +1,21 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include
+# -Wsystem-headers is needed to print warnings in the tracepoint
+# description file.
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 
-# We install the plugins into the /tmp/lttng-ust-divert directory to
-# please libtool, which absolutely needs a target install location. We
-# don't want to pollute the system with test program plugins.
-# We use the .so in .libs/ for the tests.
-noinst_plugins_libdir = "/tmp/lttng-ust-divert"
+# Set LIBS to nothing so the application does not link on useless
+# libraries.
+LIBS =
 
-noinst_plugins_lib_LTLIBRARIES = liblttng-ust-provider-ust-tests-demo.la \
+if NO_SHARED
+# Do not build this test if shared libraries support was
+# explicitly disabled.
+else
+# Force the shared flag on the noinst libraries since they are
+# only built static by default
+FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
+                          -rpath $(abs_builddir)
+
+noinst_LTLIBRARIES = liblttng-ust-provider-ust-tests-demo.la \
        liblttng-ust-provider-ust-tests-demo3.la
 
 #contains ust_tests_demo.h and ust_tests_demo2.h provider probes
@@ -15,14 +24,19 @@ liblttng_ust_provider_ust_tests_demo_la_SOURCES = \
        tp2.c ust_tests_demo2.h
 liblttng_ust_provider_ust_tests_demo_la_LIBADD = \
        $(top_builddir)/liblttng-ust/liblttng-ust.la
+liblttng_ust_provider_ust_tests_demo_la_LDFLAGS = \
+       $(FORCE_SHARED_LIB_OPTIONS)
 
 #contains ust_tests_demo3.h provider probes
 liblttng_ust_provider_ust_tests_demo3_la_SOURCES = \
        tp3.c ust_tests_demo3.h
 liblttng_ust_provider_ust_tests_demo3_la_LIBADD = \
        $(top_builddir)/liblttng-ust/liblttng-ust.la
+liblttng_ust_provider_ust_tests_demo3_la_LDFLAGS = \
+       $(FORCE_SHARED_LIB_OPTIONS)
 
 noinst_PROGRAMS = demo
 demo_SOURCES = demo.c ust_tests_demo.h
 # The demo program only depends on libdl.
-demo_LIBS = -ldl
+demo_LDFLAGS = -ldl
+endif
This page took 0.023379 seconds and 4 git commands to generate.