Fix: Conditionally disable tests requiring shared libs support
[lttng-ust.git] / tests / demo / Makefile.am
index 04b6e8c990f541c71e3d1f87c2c94a67f3c8e8a7..5adafdc5ff31e892e768a030633ce5cff0e3367c 100644 (file)
@@ -6,6 +6,10 @@ AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include -Wsystem-headers
 # libraries.
 LIBS =
 
+if NO_SHARED
+# Do not build this test if shared libraries support was
+# explicitly disabled.
+else
 # Force the shared flag on the noinst libraries since they are
 # only built static by default
 FORCE_SHARED_LIB_OPTIONS = -module -shared -avoid-version \
@@ -35,3 +39,4 @@ noinst_PROGRAMS = demo
 demo_SOURCES = demo.c ust_tests_demo.h
 # The demo program only depends on libdl.
 demo_LDFLAGS = -ldl
+endif
This page took 0.024369 seconds and 4 git commands to generate.