Rename "tsc" to "timestamp"
[lttng-ust.git] / tests / Makefile.am
index dd1317bea1abad3d43cc648f7af29e34009144d7..79113ce76af315a7d93d820ceee1678371431c93 100644 (file)
@@ -1,11 +1,49 @@
-SUBDIRS = . hello fork ust-basic-tracing ust-multi-test demo hello.cxx
-#SUBDIRS = . hello2 basic basic_long simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests exit-fast
+# SPDX-FileCopyrightText: 2023 EfficiOS, Inc
+#
+# SPDX-License-Identifier: LGPL-2.1-only
 
-dist_noinst_SCRIPTS = test_loop runtests trace_matches
+SUBDIRS = utils unit compile benchmark regression
 
-noinst_LIBRARIES = libtap.a
+LOG_DRIVER_FLAGS = --merge --comments
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
+       UST_TESTS_SRCDIR='$(abs_top_srcdir)/tests' \
+       UST_TESTS_BUILDDIR='$(abs_top_builddir)/tests' \
+       $(SHELL) $(srcdir)/utils/tap-driver.sh
 
-libtap_a_SOURCES = \
-       tap.c \
-       tap.h
+# Unit tests
 
+TESTS = \
+       unit/libringbuffer/test_shm \
+       unit/gcc-weak-hidden/test_gcc_weak_hidden \
+       unit/libcommon/test_get_cpu_mask_from_sysfs \
+       unit/libcommon/test_get_max_cpuid_from_mask \
+       unit/libcommon/test_get_max_cpuid_from_sysfs \
+       unit/libcommon/test_get_possible_cpus_array_len \
+       unit/libmsgpack/test_msgpack \
+       unit/pthread_name/test_pthread_name \
+       unit/snprintf/test_snprintf \
+       unit/ust-elf/test_ust_elf \
+       unit/ust-error/test_ust_error \
+       unit/ust-utils/test_ust_utils
+
+if HAVE_CXX
+TESTS += \
+       unit/ust-utils/test_ust_utils_cxx
+endif
+
+# Regression tests
+
+TESTS += \
+       regression/abi0-conflict/test_abi0_conflict
+
+EXTRA_DIST = README.md
+
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
+
+.PHONY: check-loop
This page took 0.023549 seconds and 4 git commands to generate.