Rename "tsc" to "timestamp"
[lttng-ust.git] / tests / Makefile.am
index b2c1c2b51e4cc96105a6b59c5b598640512caee6..79113ce76af315a7d93d820ceee1678371431c93 100644 (file)
@@ -1,6 +1,8 @@
+# SPDX-FileCopyrightText: 2023 EfficiOS, Inc
+#
 # SPDX-License-Identifier: LGPL-2.1-only
 
-SUBDIRS = utils unit compile benchmark
+SUBDIRS = utils unit compile benchmark regression
 
 LOG_DRIVER_FLAGS = --merge --comments
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
@@ -8,9 +10,15 @@ LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
        UST_TESTS_BUILDDIR='$(abs_top_builddir)/tests' \
        $(SHELL) $(srcdir)/utils/tap-driver.sh
 
+# Unit tests
+
 TESTS = \
        unit/libringbuffer/test_shm \
        unit/gcc-weak-hidden/test_gcc_weak_hidden \
+       unit/libcommon/test_get_cpu_mask_from_sysfs \
+       unit/libcommon/test_get_max_cpuid_from_mask \
+       unit/libcommon/test_get_max_cpuid_from_sysfs \
+       unit/libcommon/test_get_possible_cpus_array_len \
        unit/libmsgpack/test_msgpack \
        unit/pthread_name/test_pthread_name \
        unit/snprintf/test_snprintf \
@@ -23,7 +31,12 @@ TESTS += \
        unit/ust-utils/test_ust_utils_cxx
 endif
 
-EXTRA_DIST = README
+# Regression tests
+
+TESTS += \
+       regression/abi0-conflict/test_abi0_conflict
+
+EXTRA_DIST = README.md
 
 check-loop:
        while [ 0 ]; do \
This page took 0.023773 seconds and 4 git commands to generate.