Fix: Java agent: handle partial payload read
[lttng-ust.git] / tests / Makefile.am
index 6f9b969ccddbbb23fc01201d0b4a902e2a0bd3a7..c8505eb5ff77da7aec5ee633125c575abd09ef14 100644 (file)
@@ -1,14 +1,24 @@
-SUBDIRS = . hello hello-static-lib same_line_tracepoint snprintf
+SUBDIRS = utils hello same_line_tracepoint snprintf benchmark ust-elf \
+               ctf-types test-app-ctx gcc-weak-hidden hello-many
 
 if CXX_WORKS
 SUBDIRS += hello.cxx
 endif
 
-dist_noinst_SCRIPTS = test_loop runtests trace_matches
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
 
-noinst_LIBRARIES = libtap.a
+TESTS = snprintf/test_snprintf \
+       ust-elf/test_ust_elf \
+       gcc-weak-hidden/test_gcc_weak_hidden
 
-libtap_a_SOURCES = tap.c tap.h
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
 
-check-am:
-       ./run.sh unit_tests
+.PHONY: check-loop
This page took 0.022868 seconds and 4 git commands to generate.