tests: hello-many
[lttng-ust.git] / tests / Makefile.am
index 2b124228e2990484f3f35766139a366a0be6f12a..c8505eb5ff77da7aec5ee633125c575abd09ef14 100644 (file)
@@ -1,12 +1,24 @@
-SUBDIRS = . hello hello-static-lib fork ust-basic-tracing ust-multi-test \
-               demo hello.cxx daemon
-#SUBDIRS = . hello2 basic basic_long simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests exit-fast
+SUBDIRS = utils hello same_line_tracepoint snprintf benchmark ust-elf \
+               ctf-types test-app-ctx gcc-weak-hidden hello-many
 
-dist_noinst_SCRIPTS = test_loop runtests trace_matches
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
 
-noinst_LIBRARIES = libtap.a
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
 
-libtap_a_SOURCES = \
-       tap.c \
-       tap.h
+TESTS = snprintf/test_snprintf \
+       ust-elf/test_ust_elf \
+       gcc-weak-hidden/test_gcc_weak_hidden
 
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
+
+.PHONY: check-loop
This page took 0.024449 seconds and 4 git commands to generate.