Fix: race between statedump and library destructor
[lttng-ust.git] / tests / Makefile.am
index 7ebd64be3987b653a06c987f0771de8d0198475d..935c7546bbb94c2b62eefbf0b4006d321abf8fc8 100644 (file)
@@ -1,11 +1,24 @@
-SUBDIRS = . hello fork ust-basic-tracing ust-multi-test demo
-#SUBDIRS = . hello2 basic basic_long simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests exit-fast
+SUBDIRS = utils hello same_line_tracepoint snprintf benchmark ust-elf \
+               ctf-types test-app-ctx gcc-weak-hidden
 
-dist_noinst_SCRIPTS = test_loop runtests trace_matches
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
 
-noinst_LIBRARIES = libtap.a
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
 
-libtap_a_SOURCES = \
-       tap.c \
-       tap.h
+TESTS = snprintf/test_snprintf \
+       ust-elf/test_ust_elf \
+       gcc-weak-hidden/test_gcc_weak_hidden
 
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
+
+.PHONY: check-loop
This page took 0.02341 seconds and 4 git commands to generate.