Move to kernel style SPDX license identifiers
[lttng-ust.git] / tests / Makefile.am
index e4e06cebb8fd985aa41aa98e86a95409e8205c42..6ecd565fb867ca06472c016d70e1b120444f6262 100644 (file)
@@ -1,14 +1,27 @@
-SUBDIRS = . hello hello2 basic basic_long fork simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests
+# SPDX-License-Identifier: LGPL-2.1-only
 
-dist_noinst_SCRIPTS = test_loop runtests trace_matches
+SUBDIRS = utils unit compile benchmark
 
-lib_LTLIBRARIES = libtap.la
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(srcdir)/utils/tap-driver.sh
 
-libtap_la_SOURCES = \
-       tap.c \
-       tap.h
+TESTS = \
+       unit/libringbuffer/test_shm \
+       unit/gcc-weak-hidden/test_gcc_weak_hidden \
+       unit/libmsgpack/test_msgpack \
+       unit/pthread_name/test_pthread_name \
+       unit/snprintf/test_snprintf \
+       unit/ust-elf/test_ust_elf
 
-libtap_la_LDFLAGS = -no-undefined -version-info 0:0:0
+EXTRA_DIST = README
 
-libtap_la_LIBADD = \
-       -lpthread
\ No newline at end of file
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
+
+.PHONY: check-loop
This page took 0.024061 seconds and 4 git commands to generate.