Move to kernel style SPDX license identifiers
[lttng-ust.git] / tests / Makefile.am
index d46c94a58fe293e51a84d3dd456d292ebef73bbc..6ecd565fb867ca06472c016d70e1b120444f6262 100644 (file)
@@ -1,18 +1,18 @@
-SUBDIRS = utils hello same_line_tracepoint snprintf benchmark ust-elf \
-               ctf-types test-app-ctx gcc-weak-hidden hello-many pthread_name
+# SPDX-License-Identifier: LGPL-2.1-only
 
-if CXX_WORKS
-SUBDIRS += hello.cxx
-endif
+SUBDIRS = utils unit compile benchmark
 
 LOG_DRIVER_FLAGS='--merge'
 LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
-       $(top_srcdir)/config/tap-driver.sh
+       $(srcdir)/utils/tap-driver.sh
 
-TESTS = snprintf/test_snprintf \
-       ust-elf/test_ust_elf \
-       gcc-weak-hidden/test_gcc_weak_hidden \
-       pthread_name/test_pthread_name
+TESTS = \
+       unit/libringbuffer/test_shm \
+       unit/gcc-weak-hidden/test_gcc_weak_hidden \
+       unit/libmsgpack/test_msgpack \
+       unit/pthread_name/test_pthread_name \
+       unit/snprintf/test_snprintf \
+       unit/ust-elf/test_ust_elf
 
 EXTRA_DIST = README
 
This page took 0.023695 seconds and 4 git commands to generate.