Move to kernel style SPDX license identifiers
[lttng-ust.git] / tests / Makefile.am
index 425440a5160890101a31c00bc76c4d615d69305e..6ecd565fb867ca06472c016d70e1b120444f6262 100644 (file)
@@ -1,14 +1,27 @@
-SUBDIRS = . hello hello-static-lib same_line_tracepoint snprintf
+# SPDX-License-Identifier: LGPL-2.1-only
 
-if CXX_WORKS
-SUBDIRS += hello.cxx
-endif
+SUBDIRS = utils unit compile benchmark
 
-dist_noinst_SCRIPTS = test_loop run.sh trace_matches unit_tests
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(srcdir)/utils/tap-driver.sh
 
-noinst_LIBRARIES = libtap.a
+TESTS = \
+       unit/libringbuffer/test_shm \
+       unit/gcc-weak-hidden/test_gcc_weak_hidden \
+       unit/libmsgpack/test_msgpack \
+       unit/pthread_name/test_pthread_name \
+       unit/snprintf/test_snprintf \
+       unit/ust-elf/test_ust_elf
 
-libtap_a_SOURCES = tap.c tap.h
+EXTRA_DIST = README
 
-check-am:
-       ./run.sh unit_tests
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
+
+.PHONY: check-loop
This page took 0.025168 seconds and 4 git commands to generate.