Move to kernel style SPDX license identifiers
[lttng-ust.git] / tests / Makefile.am
index 061f5e21b42efcf0907aedbd16545250f8ea07ee..6ecd565fb867ca06472c016d70e1b120444f6262 100644 (file)
@@ -1 +1,27 @@
-SUBDIRS = hello hello2 basic basic_long fork simple_include snprintf test-nevents
+# SPDX-License-Identifier: LGPL-2.1-only
+
+SUBDIRS = utils unit compile benchmark
+
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(srcdir)/utils/tap-driver.sh
+
+TESTS = \
+       unit/libringbuffer/test_shm \
+       unit/gcc-weak-hidden/test_gcc_weak_hidden \
+       unit/libmsgpack/test_msgpack \
+       unit/pthread_name/test_pthread_name \
+       unit/snprintf/test_snprintf \
+       unit/ust-elf/test_ust_elf
+
+EXTRA_DIST = README
+
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
+
+.PHONY: check-loop
This page took 0.027021 seconds and 4 git commands to generate.