Disable build of libraries/tests that rely on the RTLD_NEXT GNU extension
[lttng-ust.git] / tests / Makefile.am
index 526f81c789964bf545bd1e91d89dddac3e9ad498..6672b0389ea1dc1065bf5ab0df5e96ebc7253012 100644 (file)
@@ -1,14 +1,11 @@
-SUBDIRS = . hello hello2 basic basic_long fork simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint ustcmd_function_tests
+SUBDIRS = . hello hello-static-lib ust-basic-tracing ust-multi-test demo hello.cxx
+#SUBDIRS = . hello2 basic basic_long simple_include snprintf test-nevents test-libustinstr-malloc dlopen same_line_marker trace_event register_test tracepoint libustctl_function_tests exit-fast fork
 
 dist_noinst_SCRIPTS = test_loop runtests trace_matches
 
-lib_LTLIBRARIES = libtap.la
+noinst_LIBRARIES = libtap.a
 
-libtap_la_SOURCES = \
+libtap_a_SOURCES = \
        tap.c \
        tap.h
 
-libtap_la_LDFLAGS = -no-undefined -version-info 0:0:0
-
-libtap_la_LIBADD = \
-       -lpthread
\ No newline at end of file
This page took 0.023819 seconds and 4 git commands to generate.