Add unit tests for num possible cpus
[lttng-ust.git] / tests / Makefile.am
index 2ddaceba3173d672013461dd49984fe835bf8ead..37eb6b75cdc489ec7f628224ec8a8ba5b7b3908c 100644 (file)
@@ -1 +1,26 @@
-SUBDIRS = hello hello2 basic basic_long fork simple_include
+SUBDIRS = utils hello same_line_tracepoint snprintf benchmark ust-elf \
+               ctf-types test-app-ctx gcc-weak-hidden \
+               libringbuffer
+
+if CXX_WORKS
+SUBDIRS += hello.cxx
+endif
+
+LOG_DRIVER_FLAGS='--merge'
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
+       $(top_srcdir)/config/tap-driver.sh
+
+TESTS = snprintf/test_snprintf \
+       ust-elf/test_ust_elf \
+       gcc-weak-hidden/test_gcc_weak_hidden \
+       libringbuffer/test_smp
+
+check-loop:
+       while [ 0 ]; do \
+               $(MAKE) $(AM_MAKEFLAGS) check; \
+               if [ "$$?" != "0" ]; then \
+                       break; \
+               fi \
+       done
+
+.PHONY: check-loop
This page took 0.022766 seconds and 4 git commands to generate.