Fix: allow make check to run in VPATH build
[lttng-ust.git] / tests / Makefile.am
index d9a7a30c59aacb53a5d3d0a7395de8fe4679f1b3..30b0e9a0f23897d6588bf37d8059c84c9004958a 100644 (file)
@@ -4,7 +4,23 @@ if CXX_WORKS
 SUBDIRS += hello.cxx
 endif
 
-dist_noinst_SCRIPTS = test_loop run.sh unit_tests
+SCRIPT_LIST = test_loop run.sh unit_tests
+
+dist_noinst_SCRIPTS = $(SCRIPT_LIST)
+
+all-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       cp -f $(srcdir)/$$script $(builddir); \
+               done; \
+       fi
+
+clean-local:
+       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+               for script in $(SCRIPT_LIST); do \
+                       rm -f $(builddir)/$$script; \
+               done; \
+       fi
 
 check-am:
        ./run.sh unit_tests
This page took 0.0233 seconds and 4 git commands to generate.