Add unit tests for num possible cpus
[lttng-ust.git] / tests / Makefile.am
index b1042dbef1e64c7b0307a2b528a751792e962c9c..29cfa814263f65593d5228e6b797a0379ead43de 100644 (file)
@@ -1,17 +1,35 @@
-SUBDIRS = utils hello same_line_tracepoint snprintf benchmark ust-elf \
-               ctf-types test-app-ctx gcc-weak-hidden hello-many
+# SPDX-License-Identifier: LGPL-2.1-only
 
-if CXX_WORKS
-SUBDIRS += hello.cxx
+SUBDIRS = utils unit compile benchmark regression
+
+LOG_DRIVER_FLAGS = --merge --comments
+LOG_DRIVER = env AM_TAP_AWK='$(AWK)' \
+       UST_TESTS_SRCDIR='$(abs_top_srcdir)/tests' \
+       UST_TESTS_BUILDDIR='$(abs_top_builddir)/tests' \
+       $(SHELL) $(srcdir)/utils/tap-driver.sh
+
+# Unit tests
+
+TESTS = \
+       unit/libringbuffer/test_shm \
+       unit/gcc-weak-hidden/test_gcc_weak_hidden \
+       unit/libcommon/test_smp \
+       unit/libmsgpack/test_msgpack \
+       unit/pthread_name/test_pthread_name \
+       unit/snprintf/test_snprintf \
+       unit/ust-elf/test_ust_elf \
+       unit/ust-error/test_ust_error \
+       unit/ust-utils/test_ust_utils
+
+if HAVE_CXX
+TESTS += \
+       unit/ust-utils/test_ust_utils_cxx
 endif
 
-LOG_DRIVER_FLAGS='--merge'
-LOG_DRIVER = env AM_TAP_AWK='$(AWK)' $(SHELL) \
-       $(top_srcdir)/config/tap-driver.sh
+# Regression tests
 
-TESTS = snprintf/test_snprintf \
-       ust-elf/test_ust_elf \
-       gcc-weak-hidden/test_gcc_weak_hidden
+TESTS += \
+       regression/abi0-conflict/test_abi0_conflict
 
 EXTRA_DIST = README
 
This page took 0.048113 seconds and 4 git commands to generate.