Fix: Don't override user variables within the build system
[lttng-ust.git] / snprintf / Makefile.am
index a32ed4f00f07ccd180269fcc165428ee763c6cc2..b01d13ead1aa6c6a75f3b5e7ffeb174c8ef39f31 100644 (file)
@@ -1,5 +1,5 @@
 AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm
-AM_CFLAGS = -fno-strict-aliasing
+AM_CFLAGS += -fno-strict-aliasing
 
 noinst_LTLIBRARIES = libustsnprintf.la
 libustsnprintf_la_SOURCES = \
@@ -19,4 +19,4 @@ libustsnprintf_la_SOURCES = \
        patient_write.c
 
 libustsnprintf_la_LDFLAGS = -no-undefined -static
-libustsnprintf_la_CFLAGS = -DUST_COMPONENT="lttng_ust_snprintf" -fPIC -fno-strict-aliasing
+libustsnprintf_la_CFLAGS = -DUST_COMPONENT="lttng_ust_snprintf" -fPIC $(AM_CFLAGS)
This page took 0.023506 seconds and 4 git commands to generate.