Move to kernel style SPDX license identifiers
[lttng-ust.git] / snprintf / Makefile.am
index f04846a2a881fc739604c513a13f20592648cc2c..7d9e2b647e3df8a0b0d545a70015dcb785bb51a7 100644 (file)
@@ -1,5 +1,7 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm
-AM_CFLAGS = -fno-strict-aliasing
+# SPDX-License-Identifier: LGPL-2.1-only
+
+AM_CPPFLAGS += -I$(top_srcdir)/libustcomm
+AM_CFLAGS += -fno-strict-aliasing
 
 noinst_LTLIBRARIES = libustsnprintf.la
 libustsnprintf_la_SOURCES = \
@@ -15,7 +17,10 @@ libustsnprintf_la_SOURCES = \
        vfprintf.c \
        wcio.h \
        wsetup.c \
-       core.c
+       core.c \
+       patient_write.c
 
 libustsnprintf_la_LDFLAGS = -no-undefined -static
-libustsnprintf_la_CFLAGS = -DUST_COMPONENT="ust_snprintf" -fPIC -fno-strict-aliasing
+libustsnprintf_la_CFLAGS = -DUST_COMPONENT="lttng_ust_snprintf" -fPIC $(AM_CFLAGS)
+
+EXTRA_DIST = README
This page took 0.023808 seconds and 4 git commands to generate.