Move to kernel style SPDX license identifiers
[lttng-ust.git] / snprintf / Makefile.am
index 5ef7d82697f1e5085400a6298f1d8dd592f7d488..7d9e2b647e3df8a0b0d545a70015dcb785bb51a7 100644 (file)
@@ -1,6 +1,9 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_srcdir)/libustcomm
+# SPDX-License-Identifier: LGPL-2.1-only
 
-lib_LTLIBRARIES = libustsnprintf.la
+AM_CPPFLAGS += -I$(top_srcdir)/libustcomm
+AM_CFLAGS += -fno-strict-aliasing
+
+noinst_LTLIBRARIES = libustsnprintf.la
 libustsnprintf_la_SOURCES = \
        fflush.c \
        fileext.h \
@@ -13,6 +16,11 @@ libustsnprintf_la_SOURCES = \
        various.h \
        vfprintf.c \
        wcio.h \
-       wsetup.c
-libustsnprintf_la_LDFLAGS = -no-undefined -version-info 0:0:0 -static
-libustsnprintf_la_CFLAGS = -DUST_COMPONENT="ust_snprintf" -fPIC
+       wsetup.c \
+       core.c \
+       patient_write.c
+
+libustsnprintf_la_LDFLAGS = -no-undefined -static
+libustsnprintf_la_CFLAGS = -DUST_COMPONENT="lttng_ust_snprintf" -fPIC $(AM_CFLAGS)
+
+EXTRA_DIST = README
This page took 0.022756 seconds and 4 git commands to generate.