Ring buffer: use shmp (shared-memory pointers) for per-channel shm structures
[lttng-ust.git] / libringbuffer / Makefile.am
index 226605337268dcff8e2d817ca07eb4c5fdf2c707..ffa37017c44b077d40049649e180db8490e251e5 100644 (file)
@@ -3,10 +3,13 @@ AM_CFLAGS = -fno-strict-aliasing
 
 lib_LTLIBRARIES = libringbuffer.la
 
+noinst_HEADERS = \
+       smp.h
+
 libringbuffer_la_SOURCES = \
+       smp.c \
        ring_buffer_backend.c \
-       ring_buffer_frontend.c \
-       ring_buffer_abi.c
+       ring_buffer_frontend.c
 
 libringbuffer_la_LDFLAGS = -no-undefined -version-info 0:0:0
 
This page took 0.022962 seconds and 4 git commands to generate.