Move to kernel style SPDX license identifiers
[lttng-ust.git] / libringbuffer / Makefile.am
index 9c3b99380305186f62a33a2060709664eac505c2..631a3568cc23885f8bbe5a835fbd34afb11b5d3e 100644 (file)
@@ -1,4 +1,5 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
+# SPDX-License-Identifier: LGPL-2.1-only
+
 AM_CFLAGS += -fno-strict-aliasing
 
 noinst_LTLIBRARIES = libringbuffer.la
@@ -8,13 +9,16 @@ libringbuffer_la_SOURCES = \
        shm.c shm.h shm_types.h shm_internal.h \
        ring_buffer_backend.c \
        ring_buffer_frontend.c \
-       api.h \
+       api.h mmap.h \
        backend.h backend_internal.h backend_types.h \
        frontend_api.h frontend.h frontend_internal.h frontend_types.h \
        nohz.h vatomic.h rb-init.h
 
 libringbuffer_la_LIBADD = \
-       -lpthread \
        -lrt
 
+if HAVE_LIBNUMA
+libringbuffer_la_LIBADD += -lnuma
+endif
+
 libringbuffer_la_CFLAGS = -DUST_COMPONENT="libringbuffer" $(AM_CFLAGS)
This page took 0.023419 seconds and 4 git commands to generate.