Move to kernel style SPDX license identifiers
[lttng-ust.git] / libringbuffer / Makefile.am
index 2fe76816b4964d850cb6251272a337c0bb01d617..631a3568cc23885f8bbe5a835fbd34afb11b5d3e 100644 (file)
@@ -1,22 +1,24 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include
-AM_CFLAGS = -fno-strict-aliasing
+# SPDX-License-Identifier: LGPL-2.1-only
 
-lib_LTLIBRARIES = libringbuffer.la
+AM_CFLAGS += -fno-strict-aliasing
 
-noinst_HEADERS = \
-       smp.h
+noinst_LTLIBRARIES = libringbuffer.la
 
 libringbuffer_la_SOURCES = \
-       shm.c \
-       smp.c \
+       smp.h smp.c getcpu.h \
+       shm.c shm.h shm_types.h shm_internal.h \
        ring_buffer_backend.c \
-       ring_buffer_frontend.c
-
-libringbuffer_la_LDFLAGS = -no-undefined -version-info 0:0:0
+       ring_buffer_frontend.c \
+       api.h mmap.h \
+       backend.h backend_internal.h backend_types.h \
+       frontend_api.h frontend.h frontend_internal.h frontend_types.h \
+       nohz.h vatomic.h rb-init.h
 
 libringbuffer_la_LIBADD = \
-       -lpthread \
-       -lrt \
-       $(top_builddir)/snprintf/libustsnprintf.la
+       -lrt
+
+if HAVE_LIBNUMA
+libringbuffer_la_LIBADD += -lnuma
+endif
 
-libringbuffer_la_CFLAGS = -DUST_COMPONENT="libringbuffer" -fno-strict-aliasing
+libringbuffer_la_CFLAGS = -DUST_COMPONENT="libringbuffer" $(AM_CFLAGS)
This page took 0.023331 seconds and 4 git commands to generate.