Cygwin: Pass file paths instead of file descriptors over UNIX sockets
[lttng-ust.git] / libringbuffer / Makefile.am
index bc2c7a727db05d5d3e3c65453bfa1a3b6821dace..0148a030a6d049bebaf2ee460a26483c760c481c 100644 (file)
@@ -1,22 +1,21 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include
+AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
 AM_CFLAGS = -fno-strict-aliasing
 
-lib_LTLIBRARIES = libringbuffer.la
+noinst_LTLIBRARIES = libringbuffer.la
 
 libringbuffer_la_SOURCES = \
+       smp.h smp.c getcpu.h \
+       shm.c shm.h shm_types.h shm_internal.h \
        ring_buffer_backend.c \
        ring_buffer_frontend.c \
-       ring_buffer_iterator.c \
-       ring_buffer_vfs.c \
-       ring_buffer_splice.c \
-       ring_buffer_mmap.c \
-       ../libprio_heap/lttng_prio_heap.c
-
-libringbuffer_la_LDFLAGS = -no-undefined -version-info 0:0:0
+       api.h \
+       backend.h backend_internal.h backend_types.h \
+       frontend_api.h frontend.h frontend_internal.h frontend_types.h \
+       nohz.h vatomic.h tlsfixup.h
 
 libringbuffer_la_LIBADD = \
        -lpthread \
        -lrt \
-       $(top_builddir)/snprintf/libustsnprintf.la
+       -luuid
 
 libringbuffer_la_CFLAGS = -DUST_COMPONENT="libringbuffer" -fno-strict-aliasing
This page took 0.023304 seconds and 4 git commands to generate.