Fix: race between lttng-ust getenv() and application setenv()
[lttng-ust.git] / liblttng-ust / Makefile.am
index f1801cf59e17f2cedbe9b4a09f65a55e724e9084..e79591a838f9ac9612356aed41fb7856c9edeb4e 100644 (file)
@@ -14,6 +14,7 @@ liblttng_ust_tracepoint_la_SOURCES = \
        error.h
 liblttng_ust_tracepoint_la_LIBADD = \
        -lurcu-bp \
+       -lpthread \
        $(top_builddir)/snprintf/libustsnprintf.la
 liblttng_ust_tracepoint_la_LDFLAGS = -no-undefined -version-info $(LTTNG_UST_LIBRARY_VERSION)
 liblttng_ust_tracepoint_la_CFLAGS = -DUST_COMPONENT="liblttng_ust_tracepoint" -fno-strict-aliasing
@@ -42,6 +43,8 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-ust-statedump.c \
        lttng-ust-statedump.h \
        lttng-ust-statedump-provider.h \
+       ust_lib.c \
+       ust_lib.h \
        tracepoint-internal.h \
        clock.h \
        compat.h \
@@ -53,17 +56,22 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-ust-tracef-provider.h \
        tracelog.c \
        lttng-ust-tracelog-provider.h \
-       getenv.h
+       getenv.h \
+       string-utils.c \
+       string-utils.h
 
 if HAVE_PERF_EVENT
 liblttng_ust_runtime_la_SOURCES += \
-       lttng-context-perf-counters.c
+       lttng-context-perf-counters.c \
+       perf_event.h
 endif
 
 liblttng_ust_support_la_SOURCES = \
        lttng-tracer.h \
        lttng-tracer-core.h \
        ust-core.c \
+       getenv.h \
+       getenv.c \
        lttng-ust-dynamic-type.c \
        lttng-rb-clients.h \
        lttng-ring-buffer-client.h \
This page took 0.022966 seconds and 4 git commands to generate.