bytecode: initialize all contexts on event notifier group creation
[lttng-ust.git] / liblttng-ust / Makefile.am
index 3c7da7e6275ef8c979ce026f5675939219437c85..98fb2153d3ebafdbe49c67da8f4ebb8c3bb7308e 100644 (file)
@@ -1,5 +1,4 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
-AM_CFLAGS += -fno-strict-aliasing
+AM_CFLAGS += -I$(srcdir) -fno-strict-aliasing
 
 noinst_LTLIBRARIES = liblttng-ust-runtime.la liblttng-ust-support.la
 
@@ -14,7 +13,7 @@ liblttng_ust_tracepoint_la_SOURCES = \
        error.h
 
 liblttng_ust_tracepoint_la_LIBADD = \
-       -lurcu-bp \
+       $(URCU_BP_LIBS) \
        $(top_builddir)/snprintf/libustsnprintf.la \
        $(DL_LIBS)
 
@@ -22,9 +21,15 @@ liblttng_ust_tracepoint_la_LDFLAGS = -no-undefined -version-info $(LTTNG_UST_LIB
 liblttng_ust_tracepoint_la_CFLAGS = -DUST_COMPONENT="liblttng_ust_tracepoint" $(AM_CFLAGS)
 
 liblttng_ust_runtime_la_SOURCES = \
+       bytecode.h \
        lttng-ust-comm.c \
        lttng-ust-abi.c \
        lttng-probes.c \
+       lttng-bytecode.c \
+       lttng-bytecode.h \
+       lttng-bytecode-validator.c \
+       lttng-bytecode-specialize.c \
+       lttng-bytecode-interpreter.c \
        lttng-context-provider.c \
        lttng-context-vtid.c \
        lttng-context-vpid.c \
@@ -48,12 +53,6 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-context-vsgid.c \
        lttng-context.c \
        lttng-events.c \
-       lttng-filter.c \
-       lttng-filter.h \
-       lttng-filter-validator.c \
-       lttng-filter-specialize.c \
-       lttng-filter-interpreter.c \
-       filter-bytecode.h \
        lttng-hash-helper.h \
        lttng-ust-elf.c \
        lttng-ust-statedump.c \
@@ -61,7 +60,10 @@ liblttng_ust_runtime_la_SOURCES = \
        lttng-ust-statedump-provider.h \
        ust_lib.c \
        ust_lib.h \
+       context-internal.h \
+       context-provider-internal.h \
        tracepoint-internal.h \
+       ust-events-internal.h \
        clock.h \
        compat.h \
        wait.h \
@@ -75,6 +77,7 @@ liblttng_ust_runtime_la_SOURCES = \
        getenv.h \
        string-utils.c \
        string-utils.h \
+       event-notifier-notification.c \
        ns.h \
        creds.h
 
@@ -110,11 +113,12 @@ liblttng_ust_support_la_LIBADD = \
 
 liblttng_ust_la_LIBADD = \
        -lrt \
-       -lurcu-cds \
+       $(URCU_CDS_LIBS) \
        $(top_builddir)/snprintf/libustsnprintf.la \
        $(top_builddir)/liblttng-ust-comm/liblttng-ust-comm.la \
        liblttng-ust-tracepoint.la \
        liblttng-ust-runtime.la liblttng-ust-support.la \
+       $(top_builddir)/libmsgpack/libmsgpack.la \
        $(DL_LIBS)
 
 liblttng_ust_la_CFLAGS = -DUST_COMPONENT="liblttng_ust" $(AM_CFLAGS)
This page took 0.024903 seconds and 4 git commands to generate.