Fix: pass private data to context callbacks
[lttng-ust.git] / liblttng-ust-python-agent / Makefile.am
index 8b38132e1f7cc1c3e8185e20974cc30583b0ad1d..e5de2e0b73f4e79e7333205dd73cded8e5ed4e6f 100644 (file)
@@ -1,20 +1,13 @@
+# SPDX-License-Identifier: LGPL-2.1-only
 
-AM_CPPFLAGS = $(PYTHON_INCLUDE) -I$(top_srcdir)/include/ -I$(top_builddir)/include/
-AM_CFLAGS = -fno-strict-aliasing
-
-EXTRA_DIST = lttng_agent.py.in
-
-nodist_lttng_agent_PYTHON = lttng_agent.py
-lttng_agentdir = $(pythondir)
+# tracepoint provider: always built/installed (does not depend on Python per se)
+AM_CFLAGS += -I$(srcdir) -fno-strict-aliasing
 
 lib_LTLIBRARIES = liblttng-ust-python-agent.la
 
-nodist_liblttng_ust_python_agent_la_SOURCES = lttng_agent.py
 liblttng_ust_python_agent_la_SOURCES = lttng_ust_python.c lttng_ust_python.h
-liblttng_ust_python_agent_la_LIBADD = -lc -llttng-ust \
-               -L$(top_builddir)/liblttng-ust/.libs
-
-all:
-       $(SED) 's|LIBDIR_STR|$(libdir)|g' < $(srcdir)/lttng_agent.py.in > lttng_agent.py
+liblttng_ust_python_agent_la_LIBADD = -lc \
+       $(top_builddir)/liblttng-ust/liblttng-ust.la
 
-CLEANFILES = lttng_agent.py
+# Follow the main library soname for co-installability
+liblttng_ust_python_agent_la_LDFLAGS = -version-info $(LTTNG_UST_LIBRARY_VERSION)
This page took 0.023027 seconds and 4 git commands to generate.