Fix: Don't override user variables within the build system
[lttng-ust.git] / liblttng-ust-python-agent / Makefile.am
index 5d5b6ab180a192aff651d2960a7f1d28f6ce1eff..2c6668ae766c2549b39d05414c24aa1aa772a076 100644 (file)
@@ -1,20 +1,8 @@
-
-AM_CPPFLAGS = $(PYTHON_INCLUDE) -I$(top_srcdir)/include/
-AM_CFLAGS = -fno-strict-aliasing
-
-EXTRA_DIST = lttng_agent.py.in
-
-nodist_lttng_agent_PYTHON = lttng_agent.py
-lttng_agentdir = $(pythondir)
-
+# tracepoint provider: always built/installed (does not depend on Python per se)
+AM_CPPFLAGS = -I$(top_srcdir)/include/ \
+       -I$(top_builddir)/include/
+AM_CFLAGS += -fno-strict-aliasing
 lib_LTLIBRARIES = liblttng-ust-python-agent.la
-
-nodist_liblttng_ust_python_agent_la_SOURCES = lttng_agent.py
 liblttng_ust_python_agent_la_SOURCES = lttng_ust_python.c lttng_ust_python.h
 liblttng_ust_python_agent_la_LIBADD = -lc -llttng-ust \
-               -L$(top_builddir)/liblttng-ust/.libs
-
-all:
-       $(SED) 's|LIBDIR_STR|$(libdir)|g' < lttng_agent.py.in > lttng_agent.py
-
-CLEANFILES = lttng_agent.py
+       -L$(top_builddir)/liblttng-ust/.libs
This page took 0.022937 seconds and 4 git commands to generate.