Move to kernel style SPDX license identifiers
[lttng-ust.git] / liblttng-ust-python-agent / Makefile.am
index f80b8a3f04a026cb7eba5ee2d2747c930477ab8a..2b316a7b437d040c8115536bedd3b84bd03bda9d 100644 (file)
@@ -1,34 +1,10 @@
-# tracepoint provider
-AM_CPPFLAGS = $(PYTHON_INCLUDE) -I$(top_srcdir)/include/ \
-       -I$(top_builddir)/include/
-AM_CFLAGS = -fno-strict-aliasing
-lib_LTLIBRARIES = liblttng-ust-python-agent.la
-liblttng_ust_python_agent_la_SOURCES = lttng_ust_python.c lttng_ust_python.h
-liblttng_ust_python_agent_la_LIBADD = -lc -llttng-ust \
-       -L$(top_builddir)/liblttng-ust/.libs
-
-# Use setup.py for the installation instead of Autoconf.
-# This ease the installation process and assure a *pythonic*
-# installation.
-agent_path=lttngust
-all-local:
-       $(PYTHON) setup.py build --verbose
+# SPDX-License-Identifier: LGPL-2.1-only
 
-install-exec-local:
-       if [ "$(DESTDIR)" = "" ]; then \
-               $(PYTHON) setup.py install --prefix=$(prefix) --record install_files.txt  --verbose --no-compile $(DISTSETUPOPTS);  \
-       else \
-               $(PYTHON) setup.py install --root=$(DESTDIR) --verbose install_files.txt  --prefix=$(prefix) --no-compile $(DISTSETUPOPTS); \
-       fi
-clean-local:
-       rm -rf build
+# tracepoint provider: always built/installed (does not depend on Python per se)
+AM_CFLAGS += -I$(srcdir) -fno-strict-aliasing
 
-uninstall-local:
-       cat install_files.txt | xargs rm -rf
-       rm -rf $(DESTDIR)$(pkgpythondir)
-
-EXTRA_DIST=$(agent_path)
+lib_LTLIBRARIES = liblttng-ust-python-agent.la
 
-# Remove automake generated file before dist
-dist-hook:
-       rm -rf $(distdir)/$(agent_path)/__init__.py
+liblttng_ust_python_agent_la_SOURCES = lttng_ust_python.c lttng_ust_python.h
+liblttng_ust_python_agent_la_LIBADD = -lc \
+       $(top_builddir)/liblttng-ust/liblttng-ust.la
This page took 0.024464 seconds and 4 git commands to generate.