Move to kernel style SPDX license identifiers
[lttng-ust.git] / liblttng-ust-python-agent / Makefile.am
index 869add4878632c9c4a46c22964a19a20d83db33e..2b316a7b437d040c8115536bedd3b84bd03bda9d 100644 (file)
@@ -1,31 +1,10 @@
-# inputs/outputs
-LTTNGUST_PY_PACKAGE_DIR = $(srcdir)/lttngust
-LTTNGUST_PY_PACKAGE_FILES = agent.py cmd.py debug.py loghandler.py
-LTTNGUST_PY_PACKAGE_SRC = \
-       $(addprefix $(LTTNGUST_PY_PACKAGE_DIR)/,$(LTTNGUST_PY_PACKAGE_FILES))
-INIT_PY_IN = $(srcdir)/__init__.py.in
-INIT_PY = __init__.py
+# SPDX-License-Identifier: LGPL-2.1-only
 
-# dist files
-EXTRA_DIST = $(INIT_PY_IN) $(LTTNGUST_PY_PACKAGE_SRC)
+# tracepoint provider: always built/installed (does not depend on Python per se)
+AM_CFLAGS += -I$(srcdir) -fno-strict-aliasing
 
-# __init__.py with proper version string
-all-local: $(INIT_PY)
-
-$(INIT_PY): $(INIT_PY_IN)
-       $(SED) "s/@LTTNG_UST_VERSION@/$(PACKAGE_VERSION)/g" < $< > $@
-
-# Python package
-nodist_lttngust_PYTHON = $(LTTNGUST_PY_PACKAGE_SRC) $(INIT_PY)
-lttngustdir = $(pythondir)/lttngust
-
-# tracepoint provider
-AM_CPPFLAGS = $(PYTHON_INCLUDE) -I$(top_srcdir)/include/ \
-       -I$(top_builddir)/include/
-AM_CFLAGS = -fno-strict-aliasing
 lib_LTLIBRARIES = liblttng-ust-python-agent.la
-liblttng_ust_python_agent_la_SOURCES = lttng_ust_python.c lttng_ust_python.h
-liblttng_ust_python_agent_la_LIBADD = -lc -llttng-ust \
-       -L$(top_builddir)/liblttng-ust/.libs
 
-CLEANFILES = $(INIT_PY)
+liblttng_ust_python_agent_la_SOURCES = lttng_ust_python.c lttng_ust_python.h
+liblttng_ust_python_agent_la_LIBADD = -lc \
+       $(top_builddir)/liblttng-ust/liblttng-ust.la
This page took 0.023844 seconds and 4 git commands to generate.