Fix: Make the JNI interface actually work
[lttng-ust.git] / liblttng-ust-java / Makefile.am
index 31915d0d479b256fce1d56c613e25c72ecb872c5..9e01e045e34b78ef5c64cd423dccf6a8b83ec32b 100644 (file)
@@ -3,19 +3,20 @@ if BUILD_JNI_INTERFACE
 AM_CPPFLAGS = -I$(top_srcdir)/include
 
 lib_LTLIBRARIES = liblttng-ust-java.la
-liblttng_ust_java_la_SOURCES = LTTNG_UST.c LTTNG_UST.h lttng_ust_java.h
-dist_noinst_DATA = LTTNG_UST.java
+liblttng_ust_java_la_SOURCES = LTTngUst.c org_lttng_ust_LTTngUst.h lttng_ust_java.h
+dist_noinst_DATA = LTTngUst.java
 liblttng_ust_java_la_LIBADD = -lc -L$(top_builddir)/liblttng-ust/.libs -llttng-ust
 
-all: LTTNG_UST.class LTTNG_UST.h
+all: LTTngUst.class org_lttng_ust_LTTngUst.h
 
 clean-local:
-       rm -rf LTTNG_UST.h LTTNG_UST.class
+       rm  org_lttng_ust_LTTngUst.h
+       rm -rf org/
 
-LTTNG_UST.class: LTTNG_UST.java
-       javac -d "$(builddir)" "$(srcdir)/LTTNG_UST.java"
+LTTngUst.class: LTTngUst.java
+       javac -d "$(builddir)" "$(srcdir)/LTTngUst.java"
 
-LTTNG_UST.h: LTTNG_UST.class
-       javah -classpath ./ -jni LTTNG_UST
+org_lttng_ust_LTTngUst.h: LTTngUst.class
+       javah org.lttng.ust.LTTngUst
 
 endif
This page took 0.023224 seconds and 4 git commands to generate.