Revert "Fix: Make the JNI interface actually work"
[lttng-ust.git] / liblttng-ust-java / Makefile.am
index fb25cb7bde49062698126cfe54c0ad76724787e5..31915d0d479b256fce1d56c613e25c72ecb872c5 100644 (file)
@@ -3,19 +3,19 @@ if BUILD_JNI_INTERFACE
 AM_CPPFLAGS = -I$(top_srcdir)/include
 
 lib_LTLIBRARIES = liblttng-ust-java.la
-liblttng_ust_java_la_SOURCES = UST.c UST.h ust_java.h
-dist_noinst_DATA = UST.java
+liblttng_ust_java_la_SOURCES = LTTNG_UST.c LTTNG_UST.h lttng_ust_java.h
+dist_noinst_DATA = LTTNG_UST.java
 liblttng_ust_java_la_LIBADD = -lc -L$(top_builddir)/liblttng-ust/.libs -llttng-ust
 
-all: UST.class UST.h
+all: LTTNG_UST.class LTTNG_UST.h
 
 clean-local:
-       rm -rf UST.h UST.class
+       rm -rf LTTNG_UST.h LTTNG_UST.class
 
-UST.class: UST.java
-       javac -d "$(builddir)" "$(srcdir)/UST.java"
+LTTNG_UST.class: LTTNG_UST.java
+       javac -d "$(builddir)" "$(srcdir)/LTTNG_UST.java"
 
-UST.h: UST.class
-       javah -jni UST
+LTTNG_UST.h: LTTNG_UST.class
+       javah -classpath ./ -jni LTTNG_UST
 
 endif
This page took 0.023489 seconds and 4 git commands to generate.