Move to kernel style SPDX license identifiers
[lttng-ust.git] / liblttng-ust-cyg-profile / Makefile.am
index a3a2ff92455a91340179a1b7b183c8d4b6c0ec00..d1aa7444b032f911749f0103a2fa8cb737efd616 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: LGPL-2.1-only
+
 AM_CFLAGS += -I$(srcdir) -fno-strict-aliasing
 
 lib_LTLIBRARIES = liblttng-ust-cyg-profile.la \
@@ -11,6 +13,8 @@ liblttng_ust_cyg_profile_la_LIBADD = \
        $(top_builddir)/liblttng-ust/liblttng-ust.la \
        $(DL_LIBS)
 
+liblttng_ust_cyg_profile_la_LDFLAGS = -version-info $(LTTNG_UST_LIBRARY_VERSION)
+
 liblttng_ust_cyg_profile_fast_la_SOURCES = \
        lttng-ust-cyg-profile-fast.c \
        lttng-ust-cyg-profile-fast.h
@@ -19,4 +23,6 @@ liblttng_ust_cyg_profile_fast_la_LIBADD = \
        $(top_builddir)/liblttng-ust/liblttng-ust.la \
        $(DL_LIBS)
 
+liblttng_ust_cyg_profile_fast_la_LDFLAGS = -version-info $(LTTNG_UST_LIBRARY_VERSION)
+
 dist_noinst_SCRIPTS = run run-fast
This page took 0.022779 seconds and 4 git commands to generate.