Move to kernel style SPDX license identifiers
[lttng-ust.git] / liblttng-ust-cyg-profile / Makefile.am
index 985329877034d7b03bb5383f1db6e8d8fb7be1fc..d1aa7444b032f911749f0103a2fa8cb737efd616 100644 (file)
@@ -1,20 +1,28 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
-AM_CFLAGS = -fno-strict-aliasing
+# SPDX-License-Identifier: LGPL-2.1-only
+
+AM_CFLAGS += -I$(srcdir) -fno-strict-aliasing
+
+lib_LTLIBRARIES = liblttng-ust-cyg-profile.la \
+       liblttng-ust-cyg-profile-fast.la
 
-lib_LTLIBRARIES = liblttng-ust-cyg-profile.la
 liblttng_ust_cyg_profile_la_SOURCES = \
        lttng-ust-cyg-profile.c \
        lttng-ust-cyg-profile.h
+
 liblttng_ust_cyg_profile_la_LIBADD = \
-       -L$(top_builddir)/liblttng-ust/.libs \
-       -llttng-ust
-
-if LTTNG_UST_BUILD_WITH_LIBDL
-liblttng_ust_cyg_profile_la_LIBADD += -ldl
-endif
-if LTTNG_UST_BUILD_WITH_LIBC_DL
-liblttng_ust_cyg_profile_la_LIBADD += -lc
-endif
-
-noinst_SCRIPTS = run
-EXTRA_DIST = run
+       $(top_builddir)/liblttng-ust/liblttng-ust.la \
+       $(DL_LIBS)
+
+liblttng_ust_cyg_profile_la_LDFLAGS = -version-info $(LTTNG_UST_LIBRARY_VERSION)
+
+liblttng_ust_cyg_profile_fast_la_SOURCES = \
+       lttng-ust-cyg-profile-fast.c \
+       lttng-ust-cyg-profile-fast.h
+
+liblttng_ust_cyg_profile_fast_la_LIBADD = \
+       $(top_builddir)/liblttng-ust/liblttng-ust.la \
+       $(DL_LIBS)
+
+liblttng_ust_cyg_profile_fast_la_LDFLAGS = -version-info $(LTTNG_UST_LIBRARY_VERSION)
+
+dist_noinst_SCRIPTS = run run-fast
This page took 0.022784 seconds and 4 git commands to generate.