Move to kernel style SPDX license identifiers
[lttng-ust.git] / liblttng-ust-cyg-profile / Makefile.am
index 3b1e7ebaaa8882cc35069cfaf028e73da05673ca..d1aa7444b032f911749f0103a2fa8cb737efd616 100644 (file)
@@ -1,5 +1,6 @@
-AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
-AM_CFLAGS += -fno-strict-aliasing
+# SPDX-License-Identifier: LGPL-2.1-only
+
+AM_CFLAGS += -I$(srcdir) -fno-strict-aliasing
 
 lib_LTLIBRARIES = liblttng-ust-cyg-profile.la \
        liblttng-ust-cyg-profile-fast.la
@@ -12,6 +13,8 @@ liblttng_ust_cyg_profile_la_LIBADD = \
        $(top_builddir)/liblttng-ust/liblttng-ust.la \
        $(DL_LIBS)
 
+liblttng_ust_cyg_profile_la_LDFLAGS = -version-info $(LTTNG_UST_LIBRARY_VERSION)
+
 liblttng_ust_cyg_profile_fast_la_SOURCES = \
        lttng-ust-cyg-profile-fast.c \
        lttng-ust-cyg-profile-fast.h
@@ -20,4 +23,6 @@ liblttng_ust_cyg_profile_fast_la_LIBADD = \
        $(top_builddir)/liblttng-ust/liblttng-ust.la \
        $(DL_LIBS)
 
+liblttng_ust_cyg_profile_fast_la_LDFLAGS = -version-info $(LTTNG_UST_LIBRARY_VERSION)
+
 dist_noinst_SCRIPTS = run run-fast
This page took 0.023455 seconds and 4 git commands to generate.