Document why the fd tracker is ABI without a public header
[lttng-ust.git] / include / Makefile.am
index e703ffd094949eaf8c60b7b50d82576c5052170b..da53d95324b52c2de02477967b4cc6e30b8a5175 100644 (file)
@@ -1,23 +1,74 @@
+# SPDX-License-Identifier: LGPL-2.1-only
+
+###                    ###
+### Public API headers ###
+###                    ###
+
 nobase_include_HEADERS = \
-       ust/immediate.h \
-       ust/marker.h \
-       ust/tracepoint.h \
-       ust/define_trace.h \
-       ust/ust_trace.h \
-       ust/processor.h \
-       ust/probe.h \
-       ust/ust.h \
-       ust/tracectl.h \
-       ust/core.h \
-       ust/clock.h \
-       ust/type-serializer.h \
-       ust/kcompat/kcompat.h \
-       ust/kcompat/compiler.h \
-       ust/kcompat/jhash.h \
-       ust/kcompat/simple.h \
-       ust/kcompat/types.h \
-       ust/kcompat/stringify.h \
-       ust/ustctl.h \
-       ust/ustconsumer.h
-
-noinst_HEADERS = share.h usterr.h ust_snprintf.h
+       lttng/tracepoint.h \
+       lttng/tracepoint-rcu.h \
+       lttng/tracepoint-types.h \
+       lttng/tracepoint-event.h \
+       lttng/ust-tracepoint-event.h \
+       lttng/ust-tracepoint-event-reset.h \
+       lttng/ust-tracepoint-event-write.h \
+       lttng/ust-tracepoint-event-nowrite.h \
+       lttng/ust-events.h \
+       lttng/ust-ctl.h \
+       lttng/ust-abi.h \
+       lttng/ringbuffer-abi.h \
+       lttng/ust-tracer.h \
+       lttng/ust-compiler.h \
+       lttng/ust.h \
+       lttng/ust-endian.h \
+       lttng/ringbuffer-config.h \
+       lttng/align.h \
+       lttng/bug.h \
+       lttng/ust-error.h \
+       lttng/tracef.h \
+       lttng/lttng-ust-tracef.h \
+       lttng/tracelog.h \
+       lttng/lttng-ust-tracelog.h \
+       lttng/ust-clock.h \
+       lttng/ust-getcpu.h \
+       lttng/ust-elf.h \
+       lttng/counter-config.h \
+       lttng/urcu/pointer.h \
+       lttng/urcu/urcu-ust.h \
+       lttng/urcu/static/pointer.h \
+       lttng/urcu/static/urcu-ust.h
+
+# Auto-generated by configure.
+nobase_nodist_include_HEADERS = \
+       lttng/ust-config.h \
+       lttng/ust-version.h
+
+
+###                        ###
+### Global private headers ###
+###                        ###
+
+noinst_HEADERS = \
+       usterr-signal-safe.h \
+       ust-snprintf.h \
+       ust-bitmap.h \
+       ust-comm.h \
+       ust-compat.h \
+       ust-tid.h \
+       ust-bitfield.h \
+       ust-dlfcn.h \
+       ust-dynamic-type.h \
+       ust-helper.h \
+       ust-share.h
+
+
+# These headers should be moved to the public headers when tested and
+# documented. The symbols are still part of the ABI.
+
+# Used by the Java jni interface.
+noinst_HEADERS += \
+       ust-context-provider.h
+
+# Used by liblttng-ust-fd
+noinst_HEADERS += \
+       ust-fd.h \
This page took 0.024103 seconds and 4 git commands to generate.