Document why the fd tracker is ABI without a public header
[lttng-ust.git] / include / Makefile.am
index 6af48ae0128bfeb3533f099208b1cacaf8690e69..da53d95324b52c2de02477967b4cc6e30b8a5175 100644 (file)
@@ -1,5 +1,9 @@
 # SPDX-License-Identifier: LGPL-2.1-only
 
+###                    ###
+### Public API headers ###
+###                    ###
+
 nobase_include_HEADERS = \
        lttng/tracepoint.h \
        lttng/tracepoint-rcu.h \
@@ -29,29 +33,42 @@ nobase_include_HEADERS = \
        lttng/ust-getcpu.h \
        lttng/ust-elf.h \
        lttng/counter-config.h \
-       lttng/bitmap.h \
        lttng/urcu/pointer.h \
        lttng/urcu/urcu-ust.h \
        lttng/urcu/static/pointer.h \
        lttng/urcu/static/urcu-ust.h
 
-# note: usterr-signal-safe.h, core.h and share.h need namespace cleanup.
+# Auto-generated by configure.
+nobase_nodist_include_HEADERS = \
+       lttng/ust-config.h \
+       lttng/ust-version.h
+
+
+###                        ###
+### Global private headers ###
+###                        ###
 
 noinst_HEADERS = \
        usterr-signal-safe.h \
-       ust_snprintf.h \
+       ust-snprintf.h \
+       ust-bitmap.h \
        ust-comm.h \
-       ust-fd.h \
-       lttng/ust-tid.h \
-       lttng/bitfield.h \
-       lttng/ust-dlfcn.h \
-       lttng/ust-dynamic-type.h \
-       lttng/ust-context-provider.h \
-       helper.h \
-       share.h
+       ust-compat.h \
+       ust-tid.h \
+       ust-bitfield.h \
+       ust-dlfcn.h \
+       ust-dynamic-type.h \
+       ust-helper.h \
+       ust-share.h
 
-# Auto-generated by configure.
 
-nobase_nodist_include_HEADERS = \
-       lttng/ust-config.h \
-       lttng/ust-version.h
+# These headers should be moved to the public headers when tested and
+# documented. The symbols are still part of the ABI.
+
+# Used by the Java jni interface.
+noinst_HEADERS += \
+       ust-context-provider.h
+
+# Used by liblttng-ust-fd
+noinst_HEADERS += \
+       ust-fd.h \
This page took 0.023642 seconds and 4 git commands to generate.