Document why context provider is ABI without a public header
[lttng-ust.git] / include / Makefile.am
index 47c715b191d4387156325346c5630ad872374587..cafcb7c7cb062f4d8ca6ed807f9c0fd2758ad488 100644 (file)
@@ -1,3 +1,9 @@
+# SPDX-License-Identifier: LGPL-2.1-only
+
+###                    ###
+### Public API headers ###
+###                    ###
+
 nobase_include_HEADERS = \
        lttng/tracepoint.h \
        lttng/tracepoint-rcu.h \
@@ -25,24 +31,39 @@ nobase_include_HEADERS = \
        lttng/lttng-ust-tracelog.h \
        lttng/ust-clock.h \
        lttng/ust-getcpu.h \
-       lttng/ust-elf.h
+       lttng/ust-elf.h \
+       lttng/counter-config.h \
+       lttng/bitmap.h \
+       lttng/urcu/pointer.h \
+       lttng/urcu/urcu-ust.h \
+       lttng/urcu/static/pointer.h \
+       lttng/urcu/static/urcu-ust.h
+
+# Auto-generated by configure.
+nobase_nodist_include_HEADERS = \
+       lttng/ust-config.h \
+       lttng/ust-version.h
+
+
+###                        ###
+### Global private headers ###
+###                        ###
 
 # note: usterr-signal-safe.h, core.h and share.h need namespace cleanup.
 
 noinst_HEADERS = \
        usterr-signal-safe.h \
-       ust_snprintf.h \
+       ust-snprintf.h \
        ust-comm.h \
-       lttng/ust-tid.h \
-       lttng/bitfield.h \
-       lttng/ust-dlfcn.h \
-       lttng/ust-dynamic-type.h \
-       lttng/ust-context-provider.h \
-       helper.h \
-       share.h
-
-# Auto-generated by configure.
+       ust-fd.h \
+       ust-tid.h \
+       ust-bitfield.h \
+       ust-dlfcn.h \
+       ust-dynamic-type.h \
+       ust-helper.h \
+       ust-share.h
 
-nobase_nodist_include_HEADERS = \
-       lttng/ust-config.h \
-       lttng/ust-version.h
+# Should be moved to the public headers when tested and documented. The symbols
+# are still part of the ABI and used by the Java jni interface.
+noinst_HEADERS += \
+       ust-context-provider.h
This page took 0.023155 seconds and 4 git commands to generate.