Hide private usterr-signal-safe.h symbols
[lttng-ust.git] / include / Makefile.am
index b3598ffc859b24fc1c377baed07e7e9d142eb9d9..61a09cdc854c1b4f854dd9f47a9091096a2db61c 100644 (file)
@@ -1,3 +1,9 @@
+# SPDX-License-Identifier: LGPL-2.1-only
+
+###                    ###
+### Public API headers ###
+###                    ###
+
 nobase_include_HEADERS = \
        lttng/tracepoint.h \
        lttng/tracepoint-rcu.h \
@@ -21,22 +27,42 @@ nobase_include_HEADERS = \
        lttng/ust-error.h \
        lttng/tracef.h \
        lttng/lttng-ust-tracef.h \
-       lttng/ust-clock.h
+       lttng/tracelog.h \
+       lttng/lttng-ust-tracelog.h \
+       lttng/ust-clock.h \
+       lttng/ust-getcpu.h \
+       lttng/ust-elf.h \
+       lttng/counter-config.h \
+       lttng/urcu/pointer.h \
+       lttng/urcu/urcu-ust.h \
+       lttng/urcu/static/pointer.h \
+       lttng/urcu/static/urcu-ust.h
+
+# Auto-generated by configure.
+nobase_nodist_include_HEADERS = \
+       lttng/ust-config.h \
+       lttng/ust-version.h
 
-# note: usterr-signal-safe.h, core.h and share.h need namespace cleanup.
+
+###                        ###
+### Global private headers ###
+###                        ###
 
 noinst_HEADERS = \
        usterr-signal-safe.h \
-       ust_snprintf.h \
+       ust-snprintf.h \
+       ust-bitmap.h \
        ust-comm.h \
-       lttng/ust-tid.h \
-       lttng/bitfield.h \
-       lttng/ust-dlfcn.h \
-       helper.h \
-       share.h
-
-# Auto-generated by configure.
+       ust-compat.h \
+       ust-fd.h \
+       ust-tid.h \
+       ust-bitfield.h \
+       ust-dlfcn.h \
+       ust-dynamic-type.h \
+       ust-helper.h \
+       ust-share.h
 
-nobase_nodist_include_HEADERS = \
-       lttng/ust-config.h \
-       lttng/ust-version.h
+# Should be moved to the public headers when tested and documented. The symbols
+# are still part of the ABI and used by the Java jni interface.
+noinst_HEADERS += \
+       ust-context-provider.h
This page took 0.023622 seconds and 4 git commands to generate.