Move private headers out of 'lttng/' public header dir
[lttng-ust.git] / include / Makefile.am
index b3598ffc859b24fc1c377baed07e7e9d142eb9d9..4a9e6d39aafec8162caba3c7888ee065b67cd31f 100644 (file)
@@ -1,3 +1,9 @@
+# SPDX-License-Identifier: LGPL-2.1-only
+
+###                    ###
+### Public API headers ###
+###                    ###
+
 nobase_include_HEADERS = \
        lttng/tracepoint.h \
        lttng/tracepoint-rcu.h \
@@ -21,7 +27,27 @@ nobase_include_HEADERS = \
        lttng/ust-error.h \
        lttng/tracef.h \
        lttng/lttng-ust-tracef.h \
-       lttng/ust-clock.h
+       lttng/tracelog.h \
+       lttng/lttng-ust-tracelog.h \
+       lttng/ust-clock.h \
+       lttng/ust-getcpu.h \
+       lttng/ust-elf.h \
+       lttng/counter-config.h \
+       lttng/bitmap.h \
+       lttng/urcu/pointer.h \
+       lttng/urcu/urcu-ust.h \
+       lttng/urcu/static/pointer.h \
+       lttng/urcu/static/urcu-ust.h
+
+# Auto-generated by configure.
+nobase_nodist_include_HEADERS = \
+       lttng/ust-config.h \
+       lttng/ust-version.h
+
+
+###                        ###
+### Global private headers ###
+###                        ###
 
 # note: usterr-signal-safe.h, core.h and share.h need namespace cleanup.
 
@@ -29,14 +55,12 @@ noinst_HEADERS = \
        usterr-signal-safe.h \
        ust_snprintf.h \
        ust-comm.h \
-       lttng/ust-tid.h \
-       lttng/bitfield.h \
-       lttng/ust-dlfcn.h \
+       ust-fd.h \
+       ust-tid.h \
+       ust-bitfield.h \
+       ust-dlfcn.h \
+       ust-dynamic-type.h \
+       ust-context-provider.h \
        helper.h \
        share.h
 
-# Auto-generated by configure.
-
-nobase_nodist_include_HEADERS = \
-       lttng/ust-config.h \
-       lttng/ust-version.h
This page took 0.024169 seconds and 4 git commands to generate.