Move compat macros in 'lttng/align.h' to a private header
[lttng-ust.git] / include / Makefile.am
index a754d04b98b43ce22d0d8ebeabd95be93ff98973..2c78459efc2813b9bf760834e256bd7e9018d22e 100644 (file)
@@ -1,35 +1,70 @@
+# SPDX-License-Identifier: LGPL-2.1-only
+
+###                    ###
+### Public API headers ###
+###                    ###
+
 nobase_include_HEADERS = \
-       ust/marker.h \
-       ust/tracepoint.h \
-       ust/tracepoint-event.h \
-       ust/lttng-tracepoint-event.h \
-       ust/lttng-tracepoint-event-reset.h \
-       ust/lttng-events.h \
-       ust/version.h \
-       ust/lttng-ust-abi.h \
-       ust/ringbuffer-abi.h \
-       ust/lttng-tracer.h \
-       ust/usterr-signal-safe.h \
-       ust/core.h \
-       ust/share.h
-
-# note: usterr-signal-safe.h, core.h and share.h need namespace cleanup.
+       lttng/tracepoint.h \
+       lttng/tracepoint-rcu.h \
+       lttng/tracepoint-types.h \
+       lttng/tracepoint-event.h \
+       lttng/ust-tracepoint-event.h \
+       lttng/ust-tracepoint-event-reset.h \
+       lttng/ust-tracepoint-event-write.h \
+       lttng/ust-tracepoint-event-nowrite.h \
+       lttng/ust-events.h \
+       lttng/ust-ctl.h \
+       lttng/ust-abi.h \
+       lttng/ringbuffer-abi.h \
+       lttng/ust-tracer.h \
+       lttng/ust-compiler.h \
+       lttng/ust.h \
+       lttng/ust-endian.h \
+       lttng/ringbuffer-config.h \
+       lttng/align.h \
+       lttng/bug.h \
+       lttng/ust-error.h \
+       lttng/tracef.h \
+       lttng/lttng-ust-tracef.h \
+       lttng/tracelog.h \
+       lttng/lttng-ust-tracelog.h \
+       lttng/ust-clock.h \
+       lttng/ust-getcpu.h \
+       lttng/ust-elf.h \
+       lttng/counter-config.h \
+       lttng/urcu/pointer.h \
+       lttng/urcu/urcu-ust.h \
+       lttng/urcu/static/pointer.h \
+       lttng/urcu/static/urcu-ust.h
+
+# Auto-generated by configure.
+nobase_nodist_include_HEADERS = \
+       lttng/ust-config.h \
+       lttng/ust-version.h
+
+
+###                        ###
+### Global private headers ###
+###                        ###
+
+# note: usterr-signal-safe.h need namespace cleanup.
 
 noinst_HEADERS = \
-       lttng-ust-comm.h \
-       usterr.h \
-       ust_snprintf.h \
-       ust/compat.h \
-       ust/config.h \
-       ust/marker-internal.h \
-       ust/tracepoint-internal.h \
-       ust/clock.h \
-       ust/probe-internal.h \
-       ust/processor.h \
-       ust/kcompat/kcompat.h \
-       ust/kcompat/jhash.h \
-       ust/kcompat/compiler.h \
-       ust/kcompat/types.h \
-       ust/tracectl.h \
-       ust/stringify.h \
-       ust/wait.h
+       usterr-signal-safe.h \
+       ust-snprintf.h \
+       ust-bitmap.h \
+       ust-comm.h \
+       ust-compat.h \
+       ust-fd.h \
+       ust-tid.h \
+       ust-bitfield.h \
+       ust-dlfcn.h \
+       ust-dynamic-type.h \
+       ust-helper.h \
+       ust-share.h
+
+# Should be moved to the public headers when tested and documented. The symbols
+# are still part of the ABI and used by the Java jni interface.
+noinst_HEADERS += \
+       ust-context-provider.h
This page took 0.024434 seconds and 4 git commands to generate.