Move to kernel style SPDX license identifiers
[lttng-ust.git] / doc / examples / Makefile.am
index 493e07dd62997b83636f12d9a4267cf43211bc9b..b66acaf4db63573f918464ab03d6255eb31722fd 100644 (file)
@@ -1,3 +1,5 @@
+# SPDX-License-Identifier: LGPL-2.1-only
+
 doc_examplesdir = ${docdir}/examples
 doc_examples_easy_ustdir = ${docdir}/examples/easy-ust
 doc_examples_gen_tpdir = ${docdir}/examples/gen-tp
@@ -81,10 +83,12 @@ dist_doc_examples_hello_static_lib_DATA = hello-static-lib/Makefile \
 
 dist_doc_examples_demo_tracef_DATA = demo-tracef/Makefile \
        demo-tracef/demo-tracef.c \
+       demo-tracef/demo-vtracef.c \
        demo-tracef/README
 
 dist_doc_examples_demo_tracelog_DATA = demo-tracelog/Makefile \
        demo-tracelog/demo-tracelog.c \
+       demo-tracelog/demo-vtracelog.c \
        demo-tracelog/README
 
 dist_doc_examples_clock_override_DATA = clock-override/Makefile \
@@ -106,37 +110,64 @@ SUBDIRS_PROXY += gen-tp
 endif
 
 all-local:
-       @if [ x"$(srcdir)" != x"$(builddir)" ]; then \
+       $(AM_V_at)if [ x"$(srcdir)" != x"$(builddir)" ]; then \
                for subdir in $(SUBDIRS_PROXY) $(SUBDIRS_JUL) $(SUBDIRS_LOG4J) $(SUBDIRS_CMAKE); do \
                        cp -pfR $(srcdir)/$$subdir $(builddir); \
                        chmod -R u+w $(builddir)/$$subdir; \
                done; \
        fi; \
        if [ x"$(shell echo "$(top_srcdir)" | grep "^/" | wc -l)" = x"1" ]; then \
-               echo "Examples: absolute top_srcdir path $(top_srcdir)"; \
                rel_src_subdir=""; \
        else \
-               echo "Examples: relative top_srcdir path $(top_srcdir)"; \
                rel_src_subdir="../"; \
        fi; \
        if [ x"$(shell echo "$(top_builddir)" | grep "^/" | wc -l)" = x"1" ]; then \
-               echo "Examples: absolute top_builddir path $(top_builddir)"; \
                rel_build_subdir=""; \
        else \
-               echo "Examples: relative top_builddir path $(top_builddir)"; \
                rel_build_subdir="../"; \
        fi; \
        for subdir in $(SUBDIRS_PROXY); do \
-               (cd $$subdir && $(MAKE) CC="$(CC)" CPPFLAGS="$(CPPFLAGS)" AM_CPPFLAGS="$(AM_CPPFLAGS) -I$$rel_src_subdir$(top_srcdir)/include/ -I$$rel_build_subdir$(top_builddir)/include/" CFLAGS='$(CFLAGS)' AM_CFLAGS='$(AM_CFLAGS)' LDFLAGS="$(LDFLAGS)" AM_LDFLAGS='$(AM_LDFLAGS) -L../../../liblttng-ust/.libs -Wl,-rpath="$(PWD)/../../liblttng-ust/.libs/" -Wl,-rpath-link="$(PWD)/../../liblttng-ust/.libs/"' LTTNG_GEN_TP_PATH="../../../tools/" $(AM_MAKEFLAGS) all && cd ..) || exit 1; \
+               ( \
+                       cd $$subdir && \
+                       $(MAKE) all \
+                               AR="$(AR)" \
+                               CC="$(CC)" \
+                               CPPFLAGS="$(CPPFLAGS)" \
+                               AM_CPPFLAGS="$(AM_CPPFLAGS) \
+                               -I$$rel_src_subdir$(top_srcdir)/include/ \
+                               -I$$rel_build_subdir$(top_builddir)/include/" \
+                               CFLAGS='$(CFLAGS)' \
+                               AM_CFLAGS='$(AM_CFLAGS)' \
+                               LDFLAGS="$(LDFLAGS)" \
+                               AM_LDFLAGS='$(AM_LDFLAGS) -L../../../liblttng-ust/.libs -Wl,-rpath="$(PWD)/../../liblttng-ust/.libs/" -Wl,-rpath-link="$(PWD)/../../liblttng-ust/.libs/"' \
+                               LTTNG_GEN_TP_PATH="../../../tools/" \
+                               AM_V_P="$(AM_V_P)" \
+                               AM_V_at="$(AM_V_at)" \
+                               $(AM_MAKEFLAGS) \
+               ) || exit 1; \
        done; \
        if [ x"$(SUBDIRS_JUL)" != x"" ]; then \
                for subdir in $(SUBDIRS_JUL); do \
-                       (cd $$subdir && $(MAKE) JAVA_CLASSPATH_OVERRIDE_JUL="../../../liblttng-ust-java-agent/java/lttng-ust-agent-jul" JAVA_CLASSPATH_OVERRIDE_COMMON="../../../liblttng-ust-java-agent/java/lttng-ust-agent-common" $(AM_MAKEFLAGS) all && cd ..) || exit 1; \
+                       ( \
+                               cd $$subdir && \
+                               $(MAKE) all \
+                                       CLASSPATH="$(CLASSPATH)" \
+                                       JAVA_CLASSPATH_OVERRIDE_JUL="../../../liblttng-ust-java-agent/java/lttng-ust-agent-jul" \
+                                       JAVA_CLASSPATH_OVERRIDE_COMMON="../../../liblttng-ust-java-agent/java/lttng-ust-agent-common" \
+                                       $(AM_MAKEFLAGS) \
+                       ) || exit 1; \
                done; \
        fi; \
        if [ x"$(SUBDIRS_LOG4J)" != x"" ]; then \
                for subdir in $(SUBDIRS_LOG4J); do \
-                       (cd $$subdir && $(MAKE) JAVA_CLASSPATH_OVERRIDE_LOG4J="../../../liblttng-ust-java-agent/java/lttng-ust-agent-log4j" JAVA_CLASSPATH_OVERRIDE_COMMON="../../../liblttng-ust-java-agent/java/lttng-ust-agent-common" $(AM_MAKEFLAGS) all && cd ..) || exit 1; \
+                       ( \
+                               cd $$subdir && \
+                               $(MAKE) all \
+                                       CLASSPATH="$(CLASSPATH)" \
+                                       JAVA_CLASSPATH_OVERRIDE_LOG4J="../../../liblttng-ust-java-agent/java/lttng-ust-agent-log4j" \
+                                       JAVA_CLASSPATH_OVERRIDE_COMMON="../../../liblttng-ust-java-agent/java/lttng-ust-agent-common" \
+                                       $(AM_MAKEFLAGS) \
+                       ) || exit 1; \
                done; \
        fi; \
        if [ x"$(SUBDIRS_CMAKE)" != x"" ]; then \
@@ -145,24 +176,24 @@ all-local:
                                cd $$subdir && \
                                $(MKDIR_P) build && \
                                cd build && \
-                               CC="$(CC)" \
-                               CXX="$(CXX)" \
-                               cmake \
-                               -DCMAKE_INCLUDE_PATH="$(abs_top_srcdir)/include;$(abs_top_builddir)/include" \
-                               -DCMAKE_LIBRARY_PATH="$(abs_top_builddir)/liblttng-ust/.libs" \
-                               -DCMAKE_C_FLAGS="$(AM_CFLAGS) $(AM_CPPFLAGS) $(CPPFLAGS) $(CFLAGS)" \
-                               -DCMAKE_CXX_FLAGS="$(AM_CXXFLAGS) $(AM_CPPFLAGS) $(CXXFLAGS) $(CPPFLAGS)" \
-                               -DCMAKE_EXE_LINKER_FLAGS="$(AM_LDFLAGS) $(LDFLAGS)" \
-                               .. && \
-                               $(MAKE) && \
-                               cd .. \
+                               AR="$(AR)" \
+                                       CC="$(CC)" \
+                                       CXX="$(CXX)" \
+                                       cmake \
+                                       -DCMAKE_INCLUDE_PATH="$(abs_top_srcdir)/include;$(abs_top_builddir)/include" \
+                                       -DCMAKE_LIBRARY_PATH="$(abs_top_builddir)/liblttng-ust/.libs" \
+                                       -DCMAKE_C_FLAGS="$(AM_CFLAGS) $(CPPFLAGS) $(CFLAGS)" \
+                                       -DCMAKE_CXX_FLAGS="$(AM_CXXFLAGS) $(CXXFLAGS) $(CPPFLAGS)" \
+                                       -DCMAKE_EXE_LINKER_FLAGS="$(AM_LDFLAGS) $(LDFLAGS)" \
+                                       .. && \
+                               $(MAKE) \
                        ) || exit 1; \
                done; \
        fi;
 
 
 clean-local:
-       @for subdir in $(SUBDIRS_PROXY); do \
+       $(AM_V_at)for subdir in $(SUBDIRS_PROXY); do \
                if [ -d $$subdir ]; then \
                        (cd $$subdir && $(MAKE) $(AM_MAKEFLAGS) clean && cd ..) || exit 1; \
                fi; \
This page took 0.026758 seconds and 4 git commands to generate.