Fix: tests: use DL_LIBS variable in ust multi-lib test
[lttng-tools.git] / tests / regression / ust / multi-lib / Makefile.am
index 0ce46a7ffe376ce53094120a03085974fe561d20..52a1635c24671a952736cd8fbc0e744e51574c9e 100644 (file)
@@ -3,11 +3,11 @@ EXTRA_DIST = test_multi_lib
 noinst_PROGRAMS = exec-with-callsites exec-without-callsites
 
 exec_with_callsites_SOURCES = multi-lib-test.c callsites.c
-exec_with_callsites_LDFLAGS = -ldl $(POPT_LIBS)
+exec_with_callsites_LDFLAGS = $(DL_LIBS) $(POPT_LIBS)
 exec_with_callsites_CFLAGS = $(POPT_CFLAGS) $(AM_CFLAGS) -DHAS_CALLSITES=1
 
 exec_without_callsites_SOURCES = multi-lib-test.c
-exec_without_callsites_LDFLAGS = -ldl $(POPT_LIBS) $(UST_LIBS)
+exec_without_callsites_LDFLAGS = $(DL_LIBS) $(POPT_LIBS) $(UST_LIBS)
 exec_without_callsites_LDADD = probes.o
 exec_without_callsites_CFLAGS = $(POPT_CFLAGS) $(AM_CFLAGS) -DHAS_CALLSITES=0
 
This page took 0.024213 seconds and 4 git commands to generate.